This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: CTRL-C does not work in Cygwin when using pipes

On Tue, Dec 29, 2015 at 2:31 PM, Bill Smith wrote:
> Yes, I'm trying to do this with the standard shell, bash.  We have tried using mintty or the xterm version but there were other issues.

The above implies something but I'm not sure what it is. Can you give
more detail?

mintty and xterm are terminal emulators which can't do much without a
shell inside them.
bash is among the valid shells you can use in mintty or xterm or rxvt.

The default "Cygwin terminal" icon if you set up a minimal Cygwin
installation is mintty serving as a terminal for bash.

So when you say you are trying with the standard shell I'm with you up
to the part where you say, "We have tried using mintty...but there
were other issues" because I use those together.

And since I have chosen to participate in this thread, I tried the
command in question. The success of my attempt does not mean that I
don't believe there's a problem. My setup is Windows 7/64 in a VM,
running 32-bit cygwin, mintty terminal and bash.

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]