This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: empty cron.log

On 12/18/2015 9:50 AM, Pierre A Humblet wrote:
-----Original Message-----
From: Jason Crawford
Sent: Friday, December 18, 2015 2:17 AM

Hello everyone,
     Thanks for a great offering and all the help you provide.    I've
used cygwin for a few years, but not deeply.  cron is one of the tools I
find very handy.   Recently I upgraded to Windows 10 and ran in to
problems on my Surface Pro 3.   I installed cygwin cron (latest cygwin
32bit (2.873).  Cron is 4.1-63.) and it seemed to work but as soon as I switched
my laptop to use the Microsoft ID cron as Microsoft suggest,
cron stopped working, complaining that it can not switch id's.   If I do
a fresh install of Win10, switch to the Microsoft ID, and install cygwin
and cron, cron won't even work once.   And if I do a fresh install of
Win10 and never switch to the Microsoft id, cygwin cron works fine.
When it fails, the cronevents log file complains that it can't switch user id's.

I really don't do much.  I just install cygwin with cron, emacs, ssh, inetutils,
unison, wget.  Then I start up a cygwin window as
administrator.   Then cron-config, yes (service), [] (blank CYGWIN),
yes (self), yes (start daemon).   Then I create a trivial cron file "*/1
* * * *  date >~/cron_is_running.txt".   crontab mycron     ... and I
wait a minute.  Then I invoke cronevents.

I want to try out all the features of that Microsoft touts as coming with use of
the Microsoft ID, but I don't want to lose cron.

What do we all suggest that I do next?
Is that only with Cron or also with other services such as passwordless sshd?
I don't run sshd on the machine (as far as I know). I only ssh out. That works fine without a password. But...

But I've just tried setting up sshd on two Windows machines just now. I ran in to a few complications due to being a novice, but it eventually worked on Windows 7. I've still not gotten sshd to work on Windows 10 if my ssh client is on another machine. That seems to be some sort of network connection or firewall problem. I can ssh from the local Win10 machine to the local Win10 machine though. I have only one account and I can ssh in to that without a password using authorized_keys.

Does that answer your question? Is there a simpler or more helpful way that I can gather data for you? I don't mind reinstalling the operating system if that would help.

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]