This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: 1.3.2, 1.1.8: Pipelines losing data? (Windows 2000)


Following your instructions, as well as using grep by itself, I was
not able to detect any malfunctions in ten trials each.  In every
case, two lines with cygwin at the end were proffered.

I am using ME on an hp5195 current cygwin.

Ron Cook

----- Original Message -----
From: "russell christian sears" <>
To: <>
Sent: Monday, July 02, 2001 9:21 AM
Subject: 1.3.2, 1.1.8: Pipelines losing data? (Windows 2000)

> I have found a problem using less and grep to search a file.  The file is
> available at: (It is over 1
> megabyte, so I did not include it in this message.)
> I am using bash, and a complete, current installation of cygwin.
> When I run the command `less file.txt | grep cygwin` it sometimes fails to
> find a match in the file, even though the file does contain the string.
> It seems to be sporadic, but I have been able to reproduce the problem on
> three machines, each of which ran at about 700mhz.  Other commands that
> seem to work as expected follow:
> less file.txt | cat | grep cygwin
> cat file.txt | grep cygwin
> grep cygwin file.txt
> If you have difficulty reproducing the bug, try running the command
> multiple times (eg: by repeating <up-arrow>, <enter> rapidly).  Some
> installations will only rarely have a problem, others will rarely yield
> the correct result.  On systems that usually produce the correct result,
> re-running the command rapidly seems to increase the likelihood of the
> problem
> ocurring.
> Also, the string "cygwin" always appears at the end of a line in the file,
> which may be related to this bug.
> I have tried both version 1.1.8 and the current cygwin distribution.
> (1.3.2)  Both seem to suffer from this problem.
> As a control, I've checked this against a Linux system, and the bug did
> not exist there.
> Below, the mount mode is listed as textmode.  The bug exists under binmode
> as well.
> Here is the output of cygcheck -s -v -r > cygcheck.out:
> Cygnus Win95/NT Con

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]